File Menu

Navigation:  Tools and Other Software > Matrix Patcher > Matrix Patcher User Interface >

File Menu

prev main next

Navigation:  Tools and Other Software > Matrix Patcher > Matrix Patcher User Interface >

File Menu

prev main next

Please wait. Due to its content this page might take a while to load...

This chapter explains the File Menu of the Matrix Patcher. For other sections of the user interface see the introductory chapter.

matrix-patcher_file-menu

New…

Select this option to create a new Patch. In the pop-up dialog select the size when creating a new patch. Please make sure to match the display resolution of the Pandoras Box Client!
You may change the size anytime later as well via "Resize Patch" in the Edit menu.
Please keep in mind, that Pandoras Box outputs Art-Net only if a display is connected, or at least an EDID manager that leads the graphics card to believe there is one.

Load Patch

Loads a saved Matrix Patcher project file as a PBX file.

Save Patch

Saves the current Matrix Patcher project file as a PBX file and adds the patch to an open Pandoras Box project (and spreads it to all connected PB Clients). If the patch has been already saved, this command updates the Matrix Patcher project status and the file in the Pandoras Box project in real-time.

Save Patch As...

Saves a new copy of the current Matrix Patcher project file as a PBX file and adds the patch to an open Pandoras Box project.

Save Patch As Image

Saves the current Matrix Patcher Patch file as PNG image with the previous entered patch file resolution.

Save Map as Image

Saves the current Matrix Patcher Map file as PNG image with the previous entered patch file resolution.

Update Pandoras Box

Saves the current Matrix Patcher project file and adds the patch to an open Pandoras Box project (and spreads it to all connected PB Clients). If the patch has been already saved, this command updates the Matrix Patcher project status and the file in the Pandoras Box project in real-time.

Please note: Since revision 49 the CSV format is an obsolete format. From now on, Pandoras Box version 5.3 can read the Matrix Patcher file directly. However, if you still have copies of those CSV files and want to work with them, simply drag them into the project manually. From here, Pandoras Box treats a CSV like a PBX file.

Export Map All - ReMap FX

Exports a PNG file which can be used in Pandoras Box as a media for the ReMap FX.

Export Map Lights – ReMap FX

Exports a PNG file with all LED fixtures included which can be used in Pandoras Box as a media for the ReMap FX.

Export Map Video Tiles – ReMap FX

Exports a PNG file with all video tiles included which can be used in Pandoras Box as a media for the ReMap FX.

Convert CSV File to ReMap FX

Imports a CSV file with the output [x,y] and the source [x,y] positions in pixels and exports a png file which can be used in Pandoras Box as a media for the ReMap FX.

The CSV file format should be as in the following example:

Size;1024,768;

Output X; Output Y; Source X; Source Y;

0;0;315;73

0;1;312,72

0;2;311;71

0;3;309;69

0;4; […]

 

Exit

Quits Pandoras Box Matrix Patcher.